cPanel, Inc. has released EasyApache 3.24.18 with PHP versions 5.5.12 and 5.4.28. This release addresses the PHP vulnerability CVE-2014-0185 with the fix to a bug in the FPM package. We encourage all users using our PHP hosting services to upgrade to PHP version 5.5.12 or PHP version 5.4.28.
NOTE: Please consult your developers before requesting and upgrade.
All versions of PHP version 5.5 before 5.5.12.
All versions of PHP version 5.4 before 5.4.28.
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:
CVE-2014-0185 – MEDIUM
PHP 5.5.12: Fixed bug in the FPM package related to CVE-2014-0185.
PHP 5.4.28: Fixed bug in the FPM package related to CVE-2014-0185.
cPanel, Inc. has released EasyApache 3.24.18 with the updated versions of PHP 5.4 and 5.5 to correct these issues. Unless you have disabled EasyApache updates, EasyApache will include the latest versions of PHP automatically. Run EasyApache to rebuild your profile with the latest version of PHP.