Announcement

Collapse
No announcement yet.

Unable to create or delete any files or folders in two partitions for Ubuntu

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to create or delete any files or folders in two partitions for Ubuntu

    I had windows 10 with 3 partitions. I formatted my windows partition to install the Ubuntu. But in Ubuntu, I知 unable to create or delete any files or folders in two partitions and remained from Windows (NTFS).

  • #2
    These partitions are mounted as read-only?

    Comment


    • #3
      Originally posted by Benson View Post
      These partitions are mounted as read-only?
      How can I go about checking that?

      Comment


      • #4
        Originally posted by Arthur View Post

        How can I go about checking that?
        Run the mount command. ro - means read-only rw - means read/write

        Comment


        • #5
          Yes.. It shows read only.
          How to change it?

          Comment


          • #6
            It won稚 allow read-write if the partition has read-only (ro) permissions. You値l need to remount the partition with read-write permissions to fix the issue.

            mount -o remount,rw <device>
            So if the device were /dev/sdc1 for example you can put:

            mount -o remount,rw /dev/sdc1
            During the first mounting, you do not have to include "remount,". As well if you want it to mount rw at boot, look into the /etc/fstab file and check the options column for that partition includes rw and not ro. An example might be:

            /dev/sdc1 /path/to/mount ntfs-3g defaults,rw 0 0
            Finally, if you want to know what other mount options possibly will be available to you, I suggest exploring the man page for ntfs-3g:
            https://linux.die.net/man/8/ntfs-3g

            Comment


            • #7
              Nimbus
              Much appreciated it worked, however about mounting rw at boot, I知 unable to see my partition in that file. There is just 3 partition which is my root/ and /home and swap. Would it be a good idea for me to add my partition manually and if yes might you be able to guide me on that?

              Comment


              • #8
                Yes, you can add it manually. You can utilize my line as a layout on the off chance that you'd like, simply make a point to change the device to the actual device and the mount indicate the real mount point. A while later you can test by manually unmounting the gadget, running a mount - a, and afterward checking whether it's mounted once more. Afterward, when you are able, you can do a full test by rebooting.

                Comment


                • #9
                  In the file, I have UUID rather than /dev/sdc1 so should I found it or it's alright to put /dev/sdc1 for my partition?

                  Comment


                  • #10
                    Instead of /dev/sdc1 for the first column you can place UUID=<uuid> obviously, ensure to replace <uuid> with the actual uuid.

                    Comment


                    • #11
                      I include this line /dev/** /media/arthur/*partition label* ntfs-3g defaults,rw 0 0 however nothing occurred after checking it by mount still it says ro.

                      Comment


                      • #12
                        Try to unmount the partition and then run mount -a. Afterwards check does it mount it?

                        Comment


                        • #13
                          Nothing happened, despite the fact that I'm so grateful for your assistance. I think I ought to peruse more about it. I will utilize your reference link you put toward the finish of your answer. Thanks again.

                          Comment

                          Working...
                          X