Announcement

Collapse
No announcement yet.

PLesk + webmail error "Internal Server Error UID of script "/usr/share/psa-horde/im"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PLesk + webmail error "Internal Server Error UID of script "/usr/share/psa-horde/im"

    suPHP was enabled for every PHP script which ran under apache. This caused a few issues especially for the webmail php scripts, which reside in /usr/share/psa-horde/

    -------------------------------------
    500 Internal Server Error ::
    Internal Server Error

    UID of script "/usr/share/psa-horde/imp/login.php" is smaller than min_uid
    suPHP 0.7.1
    -------------------------------------
    Fix ::
    1. Locate the suphp.conf under your Linux server
    [You can use #find / -name suphp.conf]

    Results::
    /etc/suphp.conf
    /etc/httpd/conf.d/suphp.conf

    2.Edit
    #vi /etc/httpd/conf.d/suphp.conf

    3.
    Following are the default configurations: [I have disabled them with adding comments]
    ------------------------------------------------------
    #LoadModule suphp_module modules/mod_suphp.so

    #php_admin_value engine off
    #suPHP_Engine On
    #AddHandler x-httpd-php .php .php3 .php4 .php5
    #suPHP_AddHandler x-httpd-php

    Following are the corrections ::

    <Directory "/var/www/vhosts">
    <IfModule mod_suphp.c>
    AddHandler x-httpd-php .php .php3 .php4 .php5 .phtml
    suPHP_AddHandler x-httpd-php
    suPHP_Engine on
    </IfModule>
    </Directory>
    -----------------------------------------------------------------
    save the file. Now you can access the Webmail
    --------------------------------------------------------
    This worked for both Atmail and horde client.


    This Must fix the issue for you......!!!
    Warm Regards,
    Keanu
    Support Team
Working...
X