Announcement

Collapse
No announcement yet.

Spamd failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Spamd failed

    One of my friends server had a server problem. After a restart the server was fine but he kept receiving errors as:

    spamd failed @ A restart was attempted automagically.
    Service Check Method: [check command]


    The server is on WHM..
    How i can fix it?

  • #2
    Cpanel runs a daemon[background service] that automatically checks for services that fail and restarts them if necessary. When it restarts something, it sends an email to the contact address for the server.

    Spamd is part of SpamAssassin. Its getting fail for whatever reason and chkservd (the name of this daemon) restarted it.

    These things do happens from time to time. If your friend is receiving these messages repeatedly, then he should worry about doing something. Otherwise, it's nothing serious.

    Comment


    • #3
      Would it be a mistake to go in and to delete the name of the daemon? Is there a way to fix that, or is it best to just ignore it and move on to other things?

      Comment


      • #4
        Via root SSH access try this:

        /scripts/upcp --force

        Comment


        • #5
          Try running the status command and then the restart command to see if it gives you any errors:

          For status run:

          /scripts/restartsrv_spamd --status
          To restart Spamd run

          /scripts/restartsrv_spamd

          Comment


          • #6
            Thanks all.. here is a new error now:

            [email protected] [~]# /scripts/restartsrv_spamd
            /usr/bin/perl: symbol lookup error: /usr/local/lib/perl5/5.8.8/x86_64-linux/auto/Time/HiRes/HiRes.so: undefined symbol: clock_getres

            Comment


            • #7
              Strange.. it doesn't show any error when I run the same command. I will update again..

              Comment


              • #8

                Confirmed again.. the error is there:

                [email protected] [~]# /scripts/restartsrv_spamd
                /usr/bin/perl: symbol lookup error: /usr/local/lib/perl5/5.8.8/x86_64-linux/auto/Time/HiRes/HiRes.so: undefined symbol: clock_getres

                Comment


                • #9
                  Spamd failed

                  Originally posted by neoanderson120 View Post

                  Confirmed again.. the error is there:

                  [email protected] [~]# /scripts/restartsrv_spamd
                  /usr/bin/perl: symbol lookup error: /usr/local/lib/perl5/5.8.8/x86_64-linux/auto/Time/HiRes/HiRes.so: undefined symbol: clock_getres


                  Please try reinstalling the Perl module mentioned in the path of the error message; you may use the following command to do this via root SSH access:

                  ---------------
                  # /scripts/perlinstaller --force Time::HiRes
                  ----------------

                  Comment

                  Working...
                  X