Announcement

Collapse
No announcement yet.

500 - Internal Server Error for ASP.NET Application

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • davidstephan
    replied
    1. Run the site directly on the server – depending on the configuration of your site/server, you may be able to see the real error if you load the site from a browser located on the same server. You may need to turn off ‘show friendly http errors.’
    2. Temporarily add the following within the appropriate tags in your web.config file:


    <configuration> <system.webServer> <httpErrors errorMode="Detailed" /> </system.webServer> <system.web> <customErrors mode="Off" /> <compilation debug="true" /> </system.web> </configuration>
    After you have added those, load the page again to see if you can get a more detailed error.
    • Open up IIS Manager and try to open up some of the different features by clicking on the icon. If there is an error in the web.config file and it can’t even parse it, sometimes you will get a helpful error in IIS Manager when you try to open a feature.
    • Look in Event Viewer. Sometimes you can find the detailed error logged in there, particularly Application Event Viewer.
    • Setup Failed Request Tracing. This will often give you details on the 500 error. This is especially helpful if it is an intermittent 500 error.
    • Look through the web log files. This is especially helpful for an intermittent 500 error. You can often parse the log files to see if there is a trend with a specific page that is throwing a 500 error.

    Here are some link to solve your solution:-

    http://blogs.iis.net/rickbarber/work...l-server-error
    http://stackoverflow.com/questions/5...l-server-error

    Leave a comment:


  • Nimbus
    replied
    IIS as well reports 500 with not happening log clues if there are not enough permissions on the physical home directory (i.e. IIS_IUSRS has no access).

    Leave a comment:


  • Jake_J
    replied
    In addition to the given suggestions, try to change the existingResponse attribute of the httpErrors node to Auto from Replace, or to delete that property completely.

    HTML Code:
    <httpErrors existingResponse="Replace" />
    Last edited by Jake_J; 24-02-16, 06:29 AM.

    Leave a comment:


  • Moriana
    replied
    In my case, the sin in the web.config was the following code. When I discarded this code, the web site worked fine.

    Code:
      <staticContent>
        <mimeMap fileExtension=".mp4" mimeType="video/mp4" />
      </staticContent>

    Leave a comment:


  • Sven
    replied
    With my situation, I make a mistake within my web.config file. The application key for some reason has been put under the <appSettings> tag. However, why it does not show a config error. The 500 – Internal server error is also common for analyzing the problem.

    Leave a comment:


  • KelvinSmith
    replied
    This is a general error message without giving any info on what's truly happening for security reasons. So you need to enable and see the detailed error of your web messages.

    On IIS 6

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    <compilation debug="true"/>
    </system.web>
    </configuration>
    On IIS 7

    <configuration>
    <system.webServer>
    <httpErrors errorMode="Detailed" />
    <asp scriptErrorSentToBrowser="true"/>
    </system.webServer>
    <system.web>
    <customErrors mode="Off"/>
    <compilation debug="true"/>
    </system.web>
    </configuration>

    Leave a comment:


  • Rodney
    replied
    Make sure the entry in the root web.config file as mentioned below. It fixed it for me:

    Code:
    <configuration>
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
      </system.webServer>
    </configuration>

    Leave a comment:


  • Hadley
    replied
    Be sure to have the wildcard mapping set up for MVC application on the directory.

    Leave a comment:


  • 500 - Internal Server Error for ASP.NET Application

    Hay guys,

    I'm trying to deploy an ASP.NET application. I had deployed the website to IIS, but when open it in the browser, it shows me following error message:

    Code:
     500 - Internal server error.
    
        There is a problem with the resource you are looking for, and it cannot be displayed.
    After play around with the web.config, now I'm getting:

    Code:
    The page cannot be displayed because an internal server error has occurred.
    How to fix this issue?
Working...
X