Announcement

Collapse
No announcement yet.

Problems with NoIP (Debian)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with NoIP (Debian)

    I have the following scenario;

    Host with debian and other services running on it, among these an agenda in php .. which need access from outside of my network .. I'm installing NoIP for this, I've used it before without major problems, but this time I'm getting some errors ... here follows my command and the result.

    Part 1 - root @ debian: /usr/local/src/noip-2.1.9-1# make install if [! -d / usr / local / bin]; Then mkdir -p / usr / local / bin, fi if [! -d / usr / local / etc]; Then mkdir -p / usr / local / etc; fi noip2 cp / usr / local / bin / noip2 / usr / local / bin / noip2 -C -c /tmp/no-ip2.conf Auto configuration for Linux client of no- . ip.com Read from dynupdate.no-ip.com failed (Connection reset by peer) mv /tmp/no-ip2.conf /usr/local/etc/no-ip2.conf mv: cannot obtain status "/ tmp /no-ip2.conf ": File or directory not found

    Part 2 - root @ debian : /usr/local/src/noip-2.1.9-1# / usr / local / bin / noip2 -C Auto configuration for Linux client of no-ip.com. Read from dynupdate.no-ip.com failed (Connection reset by peer) root @ debian: /usr/local/src/noip-2.1.9-1#

  • #2
    The first error is related to the second: you need to open a connection to a machine NoIP (possibly to take an initial configuration), which is failing. Because of this, the initial setting cannot be created in "/tmp/no-ip2.conf", hence the first mistake.

    The second mistake is the failure to connect again. Check your firewall, make sure that you can open outbound connections to the "dynupdate.no-ip.com" address on the specified port.

    Comment


    • #3
      Yes my firewall was blocking the connection.

      Now I need other help .. accept connections on port 80 of my linux server.. I have a remote access via ssh .. but not on port 80, could you help me with this? I am using webmin for most inclusive firewall settings ... used by the terminal command (iptables -t nat -I PREROUTING -p tcp -i eth0 -m multiport --dport 80 -j DNAT --to 192.168.x.x ) but did not work.

      Thank you!

      Comment


      • #4
        Who is your internet service provider? See if they have blocked connections on port 80 / tcp?

        Comment


        • #5
          I believe that the service provider did not block because there comes a signal via twisted pair .. or something, but I can test other right doors. I have access to it via ssh out, and when the doors were tested with gwebtools.com, it shows them closed. which in iptables command should I use here?

          I've done the dmz on my router .. but even then, the 80 did not work.

          Comment


          • #6
            when I run nmap -v external.ip, it returns me to the door "80 / tcp filtered http"
            when I run command nmap -v internal.ip, it returns "80 / tcp open http"

            Comment


            • #7
              So ... most likely your carrier blocks port 80. My suggestion is that you try another one.

              Comment


              • #8
                I tested the site, sometimes it shows the Open Door, but cannot access, sometimes it shows the door closed. If I do the test in the same network as the router, sometimes it shows me Closed, and other open. When access from another network, fully out, it shows the door open most of the time, but I cannot access.

                Comment


                • #9
                  You can try to confirm if some traffic is coming on port 80 / tcp with a sniffer (tcpdump or wireshark). Note that if you have a router before your server, it must be configured to pass port 80 / tcp as well.

                  Comment


                  • #10
                    I have already put DMZ virtual server .. did reboot four time and nothing helped man!

                    Comment


                    • #11
                      Good morning Finley... The problem is solved. I redid the settings on the router and everything worked normally.

                      Thank you for your help!

                      Comment

                      Working...
                      X