Announcement

Collapse
No announcement yet.

Cpanel query

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cpanel query

    Hi,i'll try to explain this as best as i can.
    When i type my domain name in with an extra .(dot)ie www.mysite.co.uk. the index page comes up with all my folders in,how do i stop this?
    I am guessing there would be other ways to do this as well,if i try it with other sites a forbidden message comes up,you know the message i mean.

  • #2
    Hi, could you please update us with your domain name, so we can check & get this sorted out ASAP
    Kind regards,
    Jack Daniel.

    Cloud Hosting || Managed Dedicated Server || Webhosting UK Knowledgebase

    Comment


    • #3
      There are different ways to hide directory listing.

      the first is to place:

      Options -Indexes

      In a .htaccess.


      The second is simply to upload a blank index.html file into the public_html directory.

      Comment


      • #4
        Sorry haven't got an account here as yet,too busy with the site i've got for a while.
        I still don't get what i have to do.

        Comment


        • #5
          Originally posted by Only me View Post
          Sorry haven't got an account here as yet,too busy with the site i've got for a while.
          I still don't get what i have to do.
          No problem at all. Does an index page exists for your website? Also, could you paste the directives of the .htaccess file here?

          Comment


          • #6
            When you access " www.mysite.co.uk." what you are getting is the directory listing. this is because there is no index page under your account.
            For hiding directory listing on your account you will have to either upload the index page, if you dont have
            any index page at this moment you can create a test index.html file.

            Or there is there is another workaround. With the help of .htaccess file You can disable directory listing.

            Login to your account and under document root or www directroy of your account see for .htaccess file. If you wish to see the file from cPanel
            file manager please make sure you selet " Show Hidden Files (dotfiles)" in the POP-UP " File Manager Directory Selection " and click on Go.

            Now look for file The .htaccess file allow us to make configuration changes on a per-directory basis. The .htaccess file works in Apache Web Server on both Linux/Unix and Windows operating system. Any rule added in .htaccess file will affect itís current directory where it is placed and also itís sub-directories. You may put a .htaccess file in the root folder such that it will affect the whole site.

            Most hosting companies, by default deny directory browsing, just in case if your host have not done this you need to diasble directory browsing, Just place the following line in your .htaccess file.

            Options -Indexes

            Comment


            • #7
              I put up a blank index.html page in and it worked.
              The page now comes up as a blank page.
              Should i put anything in it.

              Thanks for the replies btw.

              Comment


              • #8
                Glad to know you got it working

                Comment

                Working...
                X